I don't know... it may be my fault, but I'm having far, FAR more frustrations with OBS and Zoom under in the last six weeks than I ever did for the last year under . Thinking I may switch back.

It may not be a fair comparison, since the livestreaming setup is far more complicated than leading worship solo from a laptop with a webcam. But pipewire in particular has been a PITA, frequently crashing or going zombie. Pulseaudio has a reputation for being a nightmare, but I never had any issues with it.

Follow

I installed Debian stable, Zoom, and the OBS snap package. Minor tweaks to my convoluted jumble of PulseAudio null sinks and loopbacks, and the sound setup seems good. And hey, what’s this? VAAPI hardware encoding support configured in OBS!

Spoke too soon… the snap package maintainers forgot to give OBS access to /etc/ssl, so no joy on making TLS connections. Now I get to learn how to build a snap. Sigh.

Now building every. single. dependency. Just to add read access to /etc/ssl. Something is broken here.

So of course the snap package build file doesn’t use specific version tags of the git repositories of its dependencies. Of course it just mindlessly tracks head and pulls in breaking changes.

Sign in to participate in the conversation
arktos.social

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!